Betanet is down

Major incident BetaNet
6 hours, 50 minutes, 39 seconds

Updates

Resolved

We fixed the bug and deployed the new code.

March 27, 2020 · 17:13 PDT
Issue

Betanet is down. We are working on fixing it and bringing it back up.

March 27, 2020 · 10:23 PDT

← Back