Service TestNet seems to be down

Major Incident TestNet
4 minutes

Update

Resolved

Service is back up.

Nov 1th, 2019 17:23 PDT
Issue

Our monitoring system has found out the service TestNet is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Nov 1th, 2019 17:19 PDT