Service TestNet seems to be down

Major incident TestNet
3 minutes

Updates

Resolved

Service is back up.

November 4, 2019 · 01:19 PDT
Issue

Our monitoring system has found out the service TestNet is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

November 4, 2019 · 01:16 PDT