Service Website seems to be down

Major incident Website
4 minutes, 13 seconds

Updates

Resolved

Service is back up.

November 5, 2019 · 13:06 PDT
Issue

Our monitoring system has found out the service Website is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

November 5, 2019 · 13:02 PDT