Service Staging TestNet seems to be down

Major Incident BetaNet
5 hours

Update

Resolved

Service is back up.

Nov 10th, 2019 09:23 PST
Issue

Our monitoring system has found out the service Staging TestNet is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Nov 10th, 2019 04:23 PST