Service Staging TestNet seems to be down

Major Incident BetaNet
27 minutes

Update

Resolved

Service is back up.

Nov 11th, 2019 20:24 PST
Issue

Our monitoring system has found out the service Staging TestNet is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Nov 11th, 2019 19:57 PST