Service Staging TestNet seems to be down

Major Incident BetaNet
2 hours, 52 minutes

Update

Resolved

Service is back up.

Nov 14th, 2019 19:32 PST
Issue

Our monitoring system has found out the service Staging TestNet is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Nov 14th, 2019 16:40 PST