Service Staging TestNet seems to be down

Major incident BetaNet
9 minutes, 1 second

Updates

Resolved

Service is back up.

November 16, 2019 · 17:40 PDT
Issue

Our monitoring system has found out the service Staging TestNet is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

November 16, 2019 · 17:31 PDT

← Back