Service Staging TestNet seems to be down

Major Incident BetaNet
32 minutes

Update

Resolved

Service is back up.

Nov 19th, 2019 16:07 PST
Issue

Our monitoring system has found out the service Staging TestNet is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Nov 19th, 2019 15:35 PST